We do see signs of recovery at below mentioned timings. Our team remains focused on monitoring transaction performance and will follow up with Mastercard for updates on the root cause, resolution progress, and any additional corrective actions.
EU: 09:07 UTC US: 08:52 UTC
Posted Jul 15, 2026 - 10:52 UTC
Monitoring
Mastercard has implemented a solution to the issue identified. We continue to monitor the service to verify normal operation and we will provide a further update within 30 minutes.
Posted Jul 15, 2026 - 09:11 UTC
Investigating
Our team is continuing to investigate the issue with Mastercard. We will provide a further update within 30 minutes.
Posted Jul 15, 2026 - 08:53 UTC
Identified
We have confirmation from Mastercard that they have identified the issue and are working on a fix. We are working with Mastercard and will provide a further update within 30 minutes.
Posted Jul 15, 2026 - 07:59 UTC
Investigating
Please be advised that MasterCard traffic is not reaching our data centre as of 07:01 GMT. Our teams are investigating the incident and we will provide a further update within 30 minutes.
If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers: US: +1 844 268 8733 US International: +1 415 842 3467 Mexico Toll Free: +52 800 283 3431 NZ: +64 800 688 733 AU: +61 1800 268 873 UK: +44 800 640 4688
Posted Jul 15, 2026 - 07:23 UTC
This incident affects: US (2.0 Transactions) and EU (2.0 Transactions).