EU - BackOffice Applications Partial Outage
Incident Report for Outseer 3-D Secure
Resolved
Outseer can confirm that the incident which started at 15:40 GMT is now resolved as of 17:15 GMT and the Back Office Applications are fully operational.

If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers:
US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Apr 25, 2024 - 17:59 UTC
Monitoring
Our team has implemented a solution to the issue identified. We continue to monitor the service to verify normal operation and we will provide a further update within 30 minutes.
Posted Apr 25, 2024 - 17:30 UTC
Update
We are currently experiencing intermittent issues logging in to the BackOffice applications.
If customers retry the request, it should go through.
We are continuing to investigate and we will update as we know more.
Posted Apr 25, 2024 - 17:20 UTC
Investigating
Please be advised that an incident has been detected which impacts the components below. Our teams are investigating the incident and we will provide a further update within 30 minutes.

If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers:
US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Apr 25, 2024 - 16:52 UTC
This incident affected: EU (Back Office Applications).